ALAS2-2018-1013


Amazon Linux 2 Security Advisory: ALAS-2018-1013
Advisory Release Date: 2018-05-10 23:59 Pacific
Severity: Medium

Issue Overview:

1553531:
Stack-based buffer overflow in exec.c:hashcmd()
zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the exec.c:hashcmd() function. A local attacker could exploit this to cause a denial of service.(CVE-2018-1071 )

Stack-based buffer overflow in gen_matches_files() at compctl.c
A buffer overflow flaw was found in the zsh shell auto-complete functionality. A local, unprivileged user can create a specially crafted directory path which leads to code execution in the context of the user who tries to use auto-complete to traverse the before mentioned path. If the user affected is privileged, this leads to privilege escalation.(CVE-2018-1083 )

Buffer overflow in utils.c:checkmailpath() can lead to local arbitrary code execution
A buffer overflow flaw was found in the zsh shell check path functionality. A local, unprivileged user can create a specially crafted message file, which, if used to set a custom "you have new mail" message, leads to code execution in the context of the user who receives the message. If the user affected is privileged, this leads to privilege escalation.(CVE-2018-1100 )


Affected Packages:

zsh


Issue Correction:
Run yum update zsh to update your system.

New Packages:
noarch:
    zsh-html-5.5.1-1.amzn2.noarch

src:
    zsh-5.5.1-1.amzn2.src

x86_64:
    zsh-5.5.1-1.amzn2.x86_64
    zsh-debuginfo-5.5.1-1.amzn2.x86_64