ALAS2-2018-1020


Amazon Linux 2 Security Advisory: ALAS-2018-1020
Advisory Release Date: 2018-05-29 23:17 Pacific
Severity: Medium
References: CVE-2018-1000168 

Issue Overview:

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1. (CVE-2018-1000168 )


Affected Packages:

nghttp2


Issue Correction:
Run yum update nghttp2 to update your system.

New Packages:
src:
    nghttp2-1.31.1-1.amzn2.src

x86_64:
    nghttp2-1.31.1-1.amzn2.x86_64
    libnghttp2-1.31.1-1.amzn2.x86_64
    libnghttp2-devel-1.31.1-1.amzn2.x86_64
    nghttp2-debuginfo-1.31.1-1.amzn2.x86_64