ALAS2-2018-1042


Amazon Linux 2 Security Advisory: ALAS-2018-1042
Advisory Release Date: 2018-07-24 21:14 Pacific
Severity: Low
References: CVE-2017-15906 

Issue Overview:

The process_open function in sftp-server.c in OpenSSH before 7.6 does not properly prevent write operations in readonly mode, which allows attackers to create zero-length files.(CVE-2017-15906 )


Affected Packages:

openssh


Issue Correction:
Run yum update openssh to update your system.

New Packages:
src:
    openssh-7.4p1-16.amzn2.0.1.src

x86_64:
    openssh-7.4p1-16.amzn2.0.1.x86_64
    openssh-clients-7.4p1-16.amzn2.0.1.x86_64
    openssh-server-7.4p1-16.amzn2.0.1.x86_64
    openssh-server-sysvinit-7.4p1-16.amzn2.0.1.x86_64
    openssh-ldap-7.4p1-16.amzn2.0.1.x86_64
    openssh-keycat-7.4p1-16.amzn2.0.1.x86_64
    openssh-askpass-7.4p1-16.amzn2.0.1.x86_64
    openssh-cavs-7.4p1-16.amzn2.0.1.x86_64
    pam_ssh_agent_auth-0.10.3-2.16.amzn2.x86_64
    openssh-debuginfo-7.4p1-16.amzn2.0.1.x86_64