ALAS2-2018-1093


Amazon Linux 2 Security Advisory: ALAS-2018-1093
Advisory Release Date: 2018-10-25 23:24 Pacific
Severity: Important
References: CVE-2018-17456 

Issue Overview:

Git before 2.14.5, allows remote code execution during processing of a recursive "git clone" of a superproject if a .gitmodules file has a URL field beginning with a '-' character.(CVE-2018-17456 )


Affected Packages:

git


Issue Correction:
Run yum update git to update your system.

New Packages:
i686:
    git-2.14.5-1.amzn2.i686
    git-core-2.14.5-1.amzn2.i686
    git-core-doc-2.14.5-1.amzn2.i686
    git-daemon-2.14.5-1.amzn2.i686
    git-svn-2.14.5-1.amzn2.i686
    git-gnome-keyring-2.14.5-1.amzn2.i686
    git-debuginfo-2.14.5-1.amzn2.i686

noarch:
    git-all-2.14.5-1.amzn2.noarch
    gitweb-2.14.5-1.amzn2.noarch
    git-p4-2.14.5-1.amzn2.noarch
    git-cvs-2.14.5-1.amzn2.noarch
    git-email-2.14.5-1.amzn2.noarch
    git-gui-2.14.5-1.amzn2.noarch
    gitk-2.14.5-1.amzn2.noarch
    perl-Git-2.14.5-1.amzn2.noarch
    perl-Git-SVN-2.14.5-1.amzn2.noarch

src:
    git-2.14.5-1.amzn2.src

x86_64:
    git-2.14.5-1.amzn2.x86_64
    git-core-2.14.5-1.amzn2.x86_64
    git-core-doc-2.14.5-1.amzn2.x86_64
    git-daemon-2.14.5-1.amzn2.x86_64
    git-svn-2.14.5-1.amzn2.x86_64
    git-gnome-keyring-2.14.5-1.amzn2.x86_64
    git-debuginfo-2.14.5-1.amzn2.x86_64