ALAS2-2018-1122


Amazon Linux 2 Security Advisory: ALAS-2018-1122
Advisory Release Date: 2018-12-08 01:50 Pacific
Severity: Medium
References: CVE-2018-14526 

Issue Overview:

An issue was discovered in rsn_supp/wpa.c in wpa_supplicant 2.0 through 2.6. Under certain conditions, the integrity of EAPOL-Key messages is not checked, leading to a decryption oracle. An attacker within range of the Access Point and client can abuse the vulnerability to recover sensitive information.(CVE-2018-14526 )


Affected Packages:

wpa_supplicant


Issue Correction:
Run yum update wpa_supplicant to update your system.

New Packages:
aarch64:
    wpa_supplicant-2.6-12.amzn2.aarch64
    wpa_supplicant-debuginfo-2.6-12.amzn2.aarch64

i686:
    wpa_supplicant-2.6-12.amzn2.i686
    wpa_supplicant-debuginfo-2.6-12.amzn2.i686

src:
    wpa_supplicant-2.6-12.amzn2.src

x86_64:
    wpa_supplicant-2.6-12.amzn2.x86_64
    wpa_supplicant-debuginfo-2.6-12.amzn2.x86_64