ALAS2-2018-1132


Amazon Linux 2 Security Advisory: ALAS-2018-1132
Advisory Release Date: 2018-12-19 17:43 Pacific
Severity: Medium
References: CVE-2018-14647 

Issue Overview:

Python's elementtree C accelerator failed to initialise Expat's hash salt during initialization. This could make it easy to conduct denial of service attacks against Expat by contructing an XML document that would cause pathological hash collisions in Expat's internal data structures, consuming large amounts CPU and RAM.(CVE-2018-14647 )


Affected Packages:

python3


Issue Correction:
Run yum update python3 to update your system.

New Packages:
aarch64:
    python3-3.7.1-9.amzn2.0.1.aarch64
    python3-libs-3.7.1-9.amzn2.0.1.aarch64
    python3-devel-3.7.1-9.amzn2.0.1.aarch64
    python3-tools-3.7.1-9.amzn2.0.1.aarch64
    python3-tkinter-3.7.1-9.amzn2.0.1.aarch64
    python3-test-3.7.1-9.amzn2.0.1.aarch64
    python3-debug-3.7.1-9.amzn2.0.1.aarch64
    python3-debuginfo-3.7.1-9.amzn2.0.1.aarch64

i686:
    python3-3.7.1-9.amzn2.0.1.i686
    python3-libs-3.7.1-9.amzn2.0.1.i686
    python3-devel-3.7.1-9.amzn2.0.1.i686
    python3-tools-3.7.1-9.amzn2.0.1.i686
    python3-tkinter-3.7.1-9.amzn2.0.1.i686
    python3-test-3.7.1-9.amzn2.0.1.i686
    python3-debug-3.7.1-9.amzn2.0.1.i686
    python3-debuginfo-3.7.1-9.amzn2.0.1.i686

src:
    python3-3.7.1-9.amzn2.0.1.src

x86_64:
    python3-3.7.1-9.amzn2.0.1.x86_64
    python3-libs-3.7.1-9.amzn2.0.1.x86_64
    python3-devel-3.7.1-9.amzn2.0.1.x86_64
    python3-tools-3.7.1-9.amzn2.0.1.x86_64
    python3-tkinter-3.7.1-9.amzn2.0.1.x86_64
    python3-test-3.7.1-9.amzn2.0.1.x86_64
    python3-debug-3.7.1-9.amzn2.0.1.x86_64
    python3-debuginfo-3.7.1-9.amzn2.0.1.x86_64