ALAS2-2019-1141


Amazon Linux 2 Security Advisory: ALAS-2019-1141
Advisory Release Date: 2019-01-09 18:00 Pacific
Severity: Important

Issue Overview:

Large syslogd messages sent to journald can cause stack corruption, causing journald to crash. The version of systemd on Amazon Linux 2 is not vulnerable to privilege escalation in this case. (CVE-2018-16864 )

Large native messages to journald can cause stack corruption, leading to possible local privilege escalation.(CVE-2018-16865 )

Please note, if you have systemd-journald-remote configured over http, then you could be open to remote escalation on previous versions of the systemd package. The systemd-journald-remote service is not installed by default on Amazon Linux 2, and when installed and enabled, the default configuration is to use https. (CVE-2018-16865 )

An out-of-bounds read in journald, triggered by a specially crafted message, can be used to leak information through the journal file (CVE-2018-16866 )


Affected Packages:

systemd


Issue Correction:
Run yum update systemd then reboot your instance, to update your system.

New Packages:
aarch64:
    systemd-219-57.amzn2.0.7.aarch64
    systemd-libs-219-57.amzn2.0.7.aarch64
    systemd-devel-219-57.amzn2.0.7.aarch64
    systemd-sysv-219-57.amzn2.0.7.aarch64
    systemd-python-219-57.amzn2.0.7.aarch64
    libgudev1-219-57.amzn2.0.7.aarch64
    libgudev1-devel-219-57.amzn2.0.7.aarch64
    systemd-journal-gateway-219-57.amzn2.0.7.aarch64
    systemd-networkd-219-57.amzn2.0.7.aarch64
    systemd-resolved-219-57.amzn2.0.7.aarch64
    systemd-debuginfo-219-57.amzn2.0.7.aarch64

i686:
    systemd-219-57.amzn2.0.7.i686
    systemd-libs-219-57.amzn2.0.7.i686
    systemd-devel-219-57.amzn2.0.7.i686
    systemd-sysv-219-57.amzn2.0.7.i686
    systemd-python-219-57.amzn2.0.7.i686
    libgudev1-219-57.amzn2.0.7.i686
    libgudev1-devel-219-57.amzn2.0.7.i686
    systemd-journal-gateway-219-57.amzn2.0.7.i686
    systemd-networkd-219-57.amzn2.0.7.i686
    systemd-resolved-219-57.amzn2.0.7.i686
    systemd-debuginfo-219-57.amzn2.0.7.i686

src:
    systemd-219-57.amzn2.0.7.src

x86_64:
    systemd-219-57.amzn2.0.7.x86_64
    systemd-libs-219-57.amzn2.0.7.x86_64
    systemd-devel-219-57.amzn2.0.7.x86_64
    systemd-sysv-219-57.amzn2.0.7.x86_64
    systemd-python-219-57.amzn2.0.7.x86_64
    libgudev1-219-57.amzn2.0.7.x86_64
    libgudev1-devel-219-57.amzn2.0.7.x86_64
    systemd-journal-gateway-219-57.amzn2.0.7.x86_64
    systemd-networkd-219-57.amzn2.0.7.x86_64
    systemd-resolved-219-57.amzn2.0.7.x86_64
    systemd-debuginfo-219-57.amzn2.0.7.x86_64