ALAS2-2019-1166


Amazon Linux 2 Security Advisory: ALAS-2019-1166
Advisory Release Date: 2019-03-08 00:39 Pacific
Severity: Important
References: CVE-2018-18311 

Issue Overview:

Perl has a buffer overflow via a crafted regular expression that triggers invalid write operations.(CVE-2018-18311 )


Affected Packages:

perl


Issue Correction:
Run yum update perl to update your system.

New Packages:
aarch64:
    perl-5.16.3-294.amzn2.aarch64
    perl-libs-5.16.3-294.amzn2.aarch64
    perl-devel-5.16.3-294.amzn2.aarch64
    perl-macros-5.16.3-294.amzn2.aarch64
    perl-tests-5.16.3-294.amzn2.aarch64
    perl-Time-Piece-1.20.1-294.amzn2.aarch64
    perl-core-5.16.3-294.amzn2.aarch64
    perl-debuginfo-5.16.3-294.amzn2.aarch64

i686:
    perl-5.16.3-294.amzn2.i686
    perl-libs-5.16.3-294.amzn2.i686
    perl-devel-5.16.3-294.amzn2.i686
    perl-macros-5.16.3-294.amzn2.i686
    perl-tests-5.16.3-294.amzn2.i686
    perl-Time-Piece-1.20.1-294.amzn2.i686
    perl-core-5.16.3-294.amzn2.i686
    perl-debuginfo-5.16.3-294.amzn2.i686

noarch:
    perl-CPAN-1.9800-294.amzn2.noarch
    perl-ExtUtils-CBuilder-0.28.2.6-294.amzn2.noarch
    perl-ExtUtils-Embed-1.30-294.amzn2.noarch
    perl-ExtUtils-Install-1.58-294.amzn2.noarch
    perl-IO-Zlib-1.10-294.amzn2.noarch
    perl-Locale-Maketext-Simple-0.21-294.amzn2.noarch
    perl-Module-CoreList-2.76.02-294.amzn2.noarch
    perl-Module-Loaded-0.08-294.amzn2.noarch
    perl-Object-Accessor-0.42-294.amzn2.noarch
    perl-Package-Constants-0.02-294.amzn2.noarch
    perl-Pod-Escapes-1.04-294.amzn2.noarch

src:
    perl-5.16.3-294.amzn2.src

x86_64:
    perl-5.16.3-294.amzn2.x86_64
    perl-libs-5.16.3-294.amzn2.x86_64
    perl-devel-5.16.3-294.amzn2.x86_64
    perl-macros-5.16.3-294.amzn2.x86_64
    perl-tests-5.16.3-294.amzn2.x86_64
    perl-Time-Piece-1.20.1-294.amzn2.x86_64
    perl-core-5.16.3-294.amzn2.x86_64
    perl-debuginfo-5.16.3-294.amzn2.x86_64