ALAS2-2019-1169


Amazon Linux 2 Security Advisory: ALAS-2019-1169
Advisory Release Date: 2019-03-08 00:42 Pacific
Severity: Medium
References: CVE-2019-5010 

Issue Overview:

A null pointer dereference vulnerability was found in the certificate parsing code in Python. This causes a denial of service to applications when parsing specially crafted certificates. This vulnerability is unlikely to be triggered if application enables SSL/TLS certificate validation and accepts certificates only from trusted root certificate authorities.(CVE-2019-5010 )


Affected Packages:

python3


Issue Correction:
Run yum update python3 to update your system.

New Packages:
aarch64:
    python3-3.7.2-4.amzn2.0.1.aarch64
    python3-libs-3.7.2-4.amzn2.0.1.aarch64
    python3-devel-3.7.2-4.amzn2.0.1.aarch64
    python3-tools-3.7.2-4.amzn2.0.1.aarch64
    python3-tkinter-3.7.2-4.amzn2.0.1.aarch64
    python3-test-3.7.2-4.amzn2.0.1.aarch64
    python3-debug-3.7.2-4.amzn2.0.1.aarch64
    python3-debuginfo-3.7.2-4.amzn2.0.1.aarch64

i686:
    python3-3.7.2-4.amzn2.0.1.i686
    python3-libs-3.7.2-4.amzn2.0.1.i686
    python3-devel-3.7.2-4.amzn2.0.1.i686
    python3-tools-3.7.2-4.amzn2.0.1.i686
    python3-tkinter-3.7.2-4.amzn2.0.1.i686
    python3-test-3.7.2-4.amzn2.0.1.i686
    python3-debug-3.7.2-4.amzn2.0.1.i686
    python3-debuginfo-3.7.2-4.amzn2.0.1.i686

src:
    python3-3.7.2-4.amzn2.0.1.src

x86_64:
    python3-3.7.2-4.amzn2.0.1.x86_64
    python3-libs-3.7.2-4.amzn2.0.1.x86_64
    python3-devel-3.7.2-4.amzn2.0.1.x86_64
    python3-tools-3.7.2-4.amzn2.0.1.x86_64
    python3-tkinter-3.7.2-4.amzn2.0.1.x86_64
    python3-test-3.7.2-4.amzn2.0.1.x86_64
    python3-debug-3.7.2-4.amzn2.0.1.x86_64
    python3-debuginfo-3.7.2-4.amzn2.0.1.x86_64