ALAS2-2019-1276


Amazon Linux 2 Security Advisory: ALAS-2019-1276
Advisory Release Date: 2019-08-23 03:41 Pacific
Advisory Updated Date: 2019-08-27 21:24 Pacific
Severity: Medium

Issue Overview:

It was found that WEBrick could be forced to use an excessive amount of memory during the processing of HTTP requests, leading to a Denial of Service. An attacker could use this flaw to send huge requests to a WEBrick application, resulting in the server running out of memory. (CVE-2018-8777)

It was found that the tmpdir and tempfile modules did not sanitize their file name argument. An attacker with control over the name could create temporary files and directories outside of the dedicated directory. (CVE-2018-6914)

It was found that WEBrick did not sanitize headers sent back to clients, resulting in a response-splitting vulnerability. An attacker, able to control the server's headers, could force WEBrick into injecting additional headers to a client. (CVE-2017-17742)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6. (CVE-2018-1000073)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6. (CVE-2018-1000076)

It was found that the methods from the Dir class did not properly handle strings containing the NULL byte. An attacker, able to inject NULL bytes in a path, could possibly trigger an unspecified behavior of the ruby script. (CVE-2018-8780)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6. (CVE-2018-1000075)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6. (CVE-2018-1000078)

An issue was discovered in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. It does not taint strings that result from unpacking tainted strings with some formats. (CVE-2018-16396)

A integer underflow was found in the way String#unpack decodes the unpacking format. An attacker, able to control the unpack format, could use this flaw to disclose arbitrary parts of the application's memory. (CVE-2018-8778)

It was found that the UNIXSocket::open and UNIXServer::open ruby methods did not handle the NULL byte properly. An attacker, able to inject NULL bytes in the socket path, could possibly trigger an unspecified behavior of the ruby script. (CVE-2018-8779)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6. (CVE-2018-1000074)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6. (CVE-2018-1000077)

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6. (CVE-2018-1000079)


Affected Packages:

ruby


Issue Correction:
Run yum update ruby to update your system.

New Packages:
aarch64:
    ruby-2.0.0.648-36.amzn2.0.1.aarch64
    ruby-devel-2.0.0.648-36.amzn2.0.1.aarch64
    ruby-libs-2.0.0.648-36.amzn2.0.1.aarch64
    rubygem-bigdecimal-1.2.0-36.amzn2.0.1.aarch64
    rubygem-io-console-0.4.2-36.amzn2.0.1.aarch64
    rubygem-json-1.7.7-36.amzn2.0.1.aarch64
    rubygem-psych-2.0.0-36.amzn2.0.1.aarch64
    ruby-tcltk-2.0.0.648-36.amzn2.0.1.aarch64
    ruby-debuginfo-2.0.0.648-36.amzn2.0.1.aarch64

i686:
    ruby-2.0.0.648-36.amzn2.0.1.i686
    ruby-devel-2.0.0.648-36.amzn2.0.1.i686
    ruby-libs-2.0.0.648-36.amzn2.0.1.i686
    rubygem-bigdecimal-1.2.0-36.amzn2.0.1.i686
    rubygem-io-console-0.4.2-36.amzn2.0.1.i686
    rubygem-json-1.7.7-36.amzn2.0.1.i686
    rubygem-psych-2.0.0-36.amzn2.0.1.i686
    ruby-tcltk-2.0.0.648-36.amzn2.0.1.i686
    ruby-debuginfo-2.0.0.648-36.amzn2.0.1.i686

noarch:
    rubygems-2.0.14.1-36.amzn2.0.1.noarch
    rubygems-devel-2.0.14.1-36.amzn2.0.1.noarch
    rubygem-rake-0.9.6-36.amzn2.0.1.noarch
    ruby-irb-2.0.0.648-36.amzn2.0.1.noarch
    rubygem-rdoc-4.0.0-36.amzn2.0.1.noarch
    ruby-doc-2.0.0.648-36.amzn2.0.1.noarch
    rubygem-minitest-4.3.2-36.amzn2.0.1.noarch

src:
    ruby-2.0.0.648-36.amzn2.0.1.src

x86_64:
    ruby-2.0.0.648-36.amzn2.0.1.x86_64
    ruby-devel-2.0.0.648-36.amzn2.0.1.x86_64
    ruby-libs-2.0.0.648-36.amzn2.0.1.x86_64
    rubygem-bigdecimal-1.2.0-36.amzn2.0.1.x86_64
    rubygem-io-console-0.4.2-36.amzn2.0.1.x86_64
    rubygem-json-1.7.7-36.amzn2.0.1.x86_64
    rubygem-psych-2.0.0-36.amzn2.0.1.x86_64
    ruby-tcltk-2.0.0.648-36.amzn2.0.1.x86_64
    ruby-debuginfo-2.0.0.648-36.amzn2.0.1.x86_64