ALAS2-2019-1289


Amazon Linux 2 Security Advisory: ALAS-2019-1289
Advisory Release Date: 2019-09-13 23:17 Pacific
Advisory Updated Date: 2019-09-19 16:04 Pacific
Severity: Medium
References: CVE-2019-12450 

Issue Overview:

file_copy_fallback in gio/gfile.c in GNOME GLib 2.56.1 does not properly restrict file permissions while a copy operation is in progress. Instead, default permissions are used. (CVE-2019-12450 )


Affected Packages:

glib2


Issue Correction:
Run yum update glib2 to update your system.

New Packages:
aarch64:
    glib2-2.56.1-4.amzn2.aarch64
    glib2-devel-2.56.1-4.amzn2.aarch64
    glib2-fam-2.56.1-4.amzn2.aarch64
    glib2-static-2.56.1-4.amzn2.aarch64
    glib2-tests-2.56.1-4.amzn2.aarch64
    glib2-debuginfo-2.56.1-4.amzn2.aarch64

i686:
    glib2-2.56.1-4.amzn2.i686
    glib2-devel-2.56.1-4.amzn2.i686
    glib2-fam-2.56.1-4.amzn2.i686
    glib2-static-2.56.1-4.amzn2.i686
    glib2-tests-2.56.1-4.amzn2.i686
    glib2-debuginfo-2.56.1-4.amzn2.i686

noarch:
    glib2-doc-2.56.1-4.amzn2.noarch

src:
    glib2-2.56.1-4.amzn2.src

x86_64:
    glib2-2.56.1-4.amzn2.x86_64
    glib2-devel-2.56.1-4.amzn2.x86_64
    glib2-fam-2.56.1-4.amzn2.x86_64
    glib2-static-2.56.1-4.amzn2.x86_64
    glib2-tests-2.56.1-4.amzn2.x86_64
    glib2-debuginfo-2.56.1-4.amzn2.x86_64