ALAS2-2019-1305


Amazon Linux 2 Security Advisory: ALAS-2019-1305
Advisory Release Date: 2019-09-30 22:57 Pacific
Advisory Updated Date: 2019-10-02 23:16 Pacific
Severity: Medium

Issue Overview:

A cached side channel attack during handshakes using RSA encryption could allow for the decryption of encrypted content. This is a variant of the Adaptive Chosen Ciphertext attack (AKA Bleichenbacher attack) and affects all NSS versions prior to NSS 3.41. (CVE-2018-12404 )


Libgcrypt before 1.7.10 and 1.8.x before 1.8.3 allows a memory-cache side-channel attack on ECDSA signatures that can be mitigated through the use of blinding during the signing process in the _gcry_ecc_ecdsa_sign function in cipher/ecc-ecdsa.c, aka the Return Of the Hidden Number Problem or ROHNP. To discover an ECDSA key, the attacker needs access to either the local machine or a different virtual machine on the same physical host. (CVE-2018-0495 )


Affected Packages:

nss


Issue Correction:
Run yum update nss to update your system.

New Packages:
aarch64:
    nss-3.44.0-4.amzn2.0.2.aarch64
    nss-tools-3.44.0-4.amzn2.0.2.aarch64
    nss-sysinit-3.44.0-4.amzn2.0.2.aarch64
    nss-devel-3.44.0-4.amzn2.0.2.aarch64
    nss-pkcs11-devel-3.44.0-4.amzn2.0.2.aarch64
    nss-debuginfo-3.44.0-4.amzn2.0.2.aarch64

i686:
    nss-3.44.0-4.amzn2.0.2.i686
    nss-tools-3.44.0-4.amzn2.0.2.i686
    nss-sysinit-3.44.0-4.amzn2.0.2.i686
    nss-devel-3.44.0-4.amzn2.0.2.i686
    nss-pkcs11-devel-3.44.0-4.amzn2.0.2.i686
    nss-debuginfo-3.44.0-4.amzn2.0.2.i686

src:
    nss-3.44.0-4.amzn2.0.2.src

x86_64:
    nss-3.44.0-4.amzn2.0.2.x86_64
    nss-tools-3.44.0-4.amzn2.0.2.x86_64
    nss-sysinit-3.44.0-4.amzn2.0.2.x86_64
    nss-devel-3.44.0-4.amzn2.0.2.x86_64
    nss-pkcs11-devel-3.44.0-4.amzn2.0.2.x86_64
    nss-debuginfo-3.44.0-4.amzn2.0.2.x86_64