ALAS2-2020-1451


Amazon Linux 2 Security Advisory: ALAS-2020-1451
Advisory Release Date: 2020-07-14 02:30 Pacific
Advisory Updated Date: 2020-07-17 00:48 Pacific
Severity: Medium
References: CVE-2020-8177 

Issue Overview:

command line arguments lead to local file overwrite (CVE-2020-8177 )


Affected Packages:

curl


Issue Correction:
Run yum update curl to update your system.

New Packages:
aarch64:
    curl-7.61.1-12.amzn2.0.2.aarch64
    libcurl-7.61.1-12.amzn2.0.2.aarch64
    libcurl-devel-7.61.1-12.amzn2.0.2.aarch64
    curl-debuginfo-7.61.1-12.amzn2.0.2.aarch64

i686:
    curl-7.61.1-12.amzn2.0.2.i686
    libcurl-7.61.1-12.amzn2.0.2.i686
    libcurl-devel-7.61.1-12.amzn2.0.2.i686
    curl-debuginfo-7.61.1-12.amzn2.0.2.i686

src:
    curl-7.61.1-12.amzn2.0.2.src

x86_64:
    curl-7.61.1-12.amzn2.0.2.x86_64
    libcurl-7.61.1-12.amzn2.0.2.x86_64
    libcurl-devel-7.61.1-12.amzn2.0.2.x86_64
    curl-debuginfo-7.61.1-12.amzn2.0.2.x86_64