ALAS2-2020-1483


Amazon Linux 2 Security Advisory: ALAS-2020-1483
Advisory Release Date: 2020-09-01 00:40 Pacific
Advisory Updated Date: 2020-09-02 17:55 Pacific
Severity: Medium
References: CVE-2019-20907 

Issue Overview:

In Lib/tarfile.py in Python through 3.8.3, an attacker is able to craft a TAR archive leading to an infinite loop when opened by tarfile.open, because _proc_pax lacks header validation. (CVE-2019-20907 )


Affected Packages:

python


Issue Correction:
Run yum update python to update your system.

New Packages:
aarch64:
    python-2.7.18-1.amzn2.0.2.aarch64
    python-libs-2.7.18-1.amzn2.0.2.aarch64
    python-devel-2.7.18-1.amzn2.0.2.aarch64
    python-tools-2.7.18-1.amzn2.0.2.aarch64
    tkinter-2.7.18-1.amzn2.0.2.aarch64
    python-test-2.7.18-1.amzn2.0.2.aarch64
    python-debug-2.7.18-1.amzn2.0.2.aarch64
    python-debuginfo-2.7.18-1.amzn2.0.2.aarch64

i686:
    python-2.7.18-1.amzn2.0.2.i686
    python-libs-2.7.18-1.amzn2.0.2.i686
    python-devel-2.7.18-1.amzn2.0.2.i686
    python-tools-2.7.18-1.amzn2.0.2.i686
    tkinter-2.7.18-1.amzn2.0.2.i686
    python-test-2.7.18-1.amzn2.0.2.i686
    python-debug-2.7.18-1.amzn2.0.2.i686
    python-debuginfo-2.7.18-1.amzn2.0.2.i686

src:
    python-2.7.18-1.amzn2.0.2.src

x86_64:
    python-2.7.18-1.amzn2.0.2.x86_64
    python-libs-2.7.18-1.amzn2.0.2.x86_64
    python-devel-2.7.18-1.amzn2.0.2.x86_64
    python-tools-2.7.18-1.amzn2.0.2.x86_64
    tkinter-2.7.18-1.amzn2.0.2.x86_64
    python-test-2.7.18-1.amzn2.0.2.x86_64
    python-debug-2.7.18-1.amzn2.0.2.x86_64
    python-debuginfo-2.7.18-1.amzn2.0.2.x86_64