ALAS2-2020-1503


Amazon Linux 2 Security Advisory: ALAS-2020-1503
Advisory Release Date: 2020-10-22 17:21 Pacific
Advisory Updated Date: 2020-10-22 22:39 Pacific
Severity: Medium
References: CVE-2019-9924 

Issue Overview:

rbash in Bash before 4.4-beta2 did not prevent the shell user from modifying BASH_CMDS, thus allowing the user to execute any command with the permissions of the shell. (CVE-2019-9924 )


Affected Packages:

bash


Issue Correction:
Run yum update bash to update your system.

New Packages:
aarch64:
    bash-4.2.46-34.amzn2.aarch64
    bash-doc-4.2.46-34.amzn2.aarch64
    bash-debuginfo-4.2.46-34.amzn2.aarch64

i686:
    bash-4.2.46-34.amzn2.i686
    bash-doc-4.2.46-34.amzn2.i686
    bash-debuginfo-4.2.46-34.amzn2.i686

src:
    bash-4.2.46-34.amzn2.src

x86_64:
    bash-4.2.46-34.amzn2.x86_64
    bash-doc-4.2.46-34.amzn2.x86_64
    bash-debuginfo-4.2.46-34.amzn2.x86_64