ALAS2-2020-1531


Amazon Linux 2 Security Advisory: ALAS-2020-1531
Advisory Release Date: 2020-10-22 18:19 Pacific
Advisory Updated Date: 2020-10-22 22:35 Pacific
Severity: Medium
References: CVE-2019-17498 

Issue Overview:

In libssh2 v1.9.0 and earlier versions, the SSH_MSG_DISCONNECT logic in packet.c has an integer overflow in a bounds check, enabling an attacker to specify an arbitrary (out-of-bounds) offset for a subsequent memory read. A crafted SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. (CVE-2019-17498 )


Affected Packages:

libssh2


Issue Correction:
Run yum update libssh2 to update your system.

New Packages:
aarch64:
    libssh2-1.4.3-12.amzn2.2.3.aarch64
    libssh2-devel-1.4.3-12.amzn2.2.3.aarch64
    libssh2-debuginfo-1.4.3-12.amzn2.2.3.aarch64

i686:
    libssh2-1.4.3-12.amzn2.2.3.i686
    libssh2-devel-1.4.3-12.amzn2.2.3.i686
    libssh2-debuginfo-1.4.3-12.amzn2.2.3.i686

noarch:
    libssh2-docs-1.4.3-12.amzn2.2.3.noarch

src:
    libssh2-1.4.3-12.amzn2.2.3.src

x86_64:
    libssh2-1.4.3-12.amzn2.2.3.x86_64
    libssh2-devel-1.4.3-12.amzn2.2.3.x86_64
    libssh2-debuginfo-1.4.3-12.amzn2.2.3.x86_64