ALAS2-2021-1578


Amazon Linux 2 Security Advisory: ALAS-2021-1578
Advisory Release Date: 2021-01-05 23:34 Pacific
Advisory Updated Date: 2021-01-06 20:29 Pacific
Severity: Medium

Issue Overview:

Go before 1.14.12 and 1.15.x before 1.15.4 allows Denial of Service. (CVE-2020-28362 )

Go before 1.14.12 and 1.15.x before 1.15.5 allows Code Injection. (CVE-2020-28366 )

Go before 1.14.12 and 1.15.x before 1.15.5 allows Argument Injection. (CVE-2020-28367 )


Affected Packages:

golang


Issue Correction:
Run yum update golang to update your system.

New Packages:
aarch64:
    golang-1.15.5-1.amzn2.0.2.aarch64
    golang-bin-1.15.5-1.amzn2.0.2.aarch64

noarch:
    golang-docs-1.15.5-1.amzn2.0.2.noarch
    golang-misc-1.15.5-1.amzn2.0.2.noarch
    golang-tests-1.15.5-1.amzn2.0.2.noarch
    golang-src-1.15.5-1.amzn2.0.2.noarch

src:
    golang-1.15.5-1.amzn2.0.2.src

x86_64:
    golang-1.15.5-1.amzn2.0.2.x86_64
    golang-bin-1.15.5-1.amzn2.0.2.x86_64
    golang-race-1.15.5-1.amzn2.0.2.x86_64