ALAS2-2021-1596


Amazon Linux 2 Security Advisory: ALAS-2021-1596
Advisory Release Date: 2021-02-17 00:44 Pacific
Advisory Updated Date: 2021-02-19 22:07 Pacific
Severity: Important
References: CVE-2020-29599 

Issue Overview:

A flaw was found in ImageMagick. The -authenticate option is mishandled allowing user-controlled password set for a PDF file to possibly inject additional shell commands via coders/pdf.c. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2020-29599 )


Affected Packages:

ImageMagick


Issue Correction:
Run yum update ImageMagick to update your system.

New Packages:
aarch64:
    ImageMagick-6.9.10.68-5.amzn2.0.1.aarch64
    ImageMagick-devel-6.9.10.68-5.amzn2.0.1.aarch64
    ImageMagick-doc-6.9.10.68-5.amzn2.0.1.aarch64
    ImageMagick-perl-6.9.10.68-5.amzn2.0.1.aarch64
    ImageMagick-c++-6.9.10.68-5.amzn2.0.1.aarch64
    ImageMagick-c++-devel-6.9.10.68-5.amzn2.0.1.aarch64
    ImageMagick-debuginfo-6.9.10.68-5.amzn2.0.1.aarch64

i686:
    ImageMagick-6.9.10.68-5.amzn2.0.1.i686
    ImageMagick-devel-6.9.10.68-5.amzn2.0.1.i686
    ImageMagick-doc-6.9.10.68-5.amzn2.0.1.i686
    ImageMagick-perl-6.9.10.68-5.amzn2.0.1.i686
    ImageMagick-c++-6.9.10.68-5.amzn2.0.1.i686
    ImageMagick-c++-devel-6.9.10.68-5.amzn2.0.1.i686
    ImageMagick-debuginfo-6.9.10.68-5.amzn2.0.1.i686

src:
    ImageMagick-6.9.10.68-5.amzn2.0.1.src

x86_64:
    ImageMagick-6.9.10.68-5.amzn2.0.1.x86_64
    ImageMagick-devel-6.9.10.68-5.amzn2.0.1.x86_64
    ImageMagick-doc-6.9.10.68-5.amzn2.0.1.x86_64
    ImageMagick-perl-6.9.10.68-5.amzn2.0.1.x86_64
    ImageMagick-c++-6.9.10.68-5.amzn2.0.1.x86_64
    ImageMagick-c++-devel-6.9.10.68-5.amzn2.0.1.x86_64
    ImageMagick-debuginfo-6.9.10.68-5.amzn2.0.1.x86_64