ALAS2-2021-1628


Amazon Linux 2 Security Advisory: ALAS-2021-1628
Advisory Release Date: 2021-04-20 17:55 Pacific
Advisory Updated Date: 2021-04-21 17:58 Pacific
Severity: Important
References: CVE-2021-20277 

Issue Overview:

A flaw was found in Samba's libldb. Multiple, consecutive leading spaces in an LDAP attribute can lead to an out-of-bounds memory write, leading to a crash of the LDAP server process handling the request. The highest threat from this vulnerability is to system availability. (CVE-2021-20277 )


Affected Packages:

libldb


Issue Correction:
Run yum update libldb to update your system.

New Packages:
aarch64:
    libldb-1.5.4-2.amzn2.aarch64
    ldb-tools-1.5.4-2.amzn2.aarch64
    libldb-devel-1.5.4-2.amzn2.aarch64
    pyldb-1.5.4-2.amzn2.aarch64
    pyldb-devel-1.5.4-2.amzn2.aarch64
    libldb-debuginfo-1.5.4-2.amzn2.aarch64

i686:
    libldb-1.5.4-2.amzn2.i686
    ldb-tools-1.5.4-2.amzn2.i686
    libldb-devel-1.5.4-2.amzn2.i686
    pyldb-1.5.4-2.amzn2.i686
    pyldb-devel-1.5.4-2.amzn2.i686
    libldb-debuginfo-1.5.4-2.amzn2.i686

src:
    libldb-1.5.4-2.amzn2.src

x86_64:
    libldb-1.5.4-2.amzn2.x86_64
    ldb-tools-1.5.4-2.amzn2.x86_64
    libldb-devel-1.5.4-2.amzn2.x86_64
    pyldb-1.5.4-2.amzn2.x86_64
    pyldb-devel-1.5.4-2.amzn2.x86_64
    libldb-debuginfo-1.5.4-2.amzn2.x86_64