ALAS2-2021-1638


Amazon Linux 2 Security Advisory: ALAS-2021-1638
Advisory Release Date: 2021-05-20 15:59 Pacific
Advisory Updated Date: 2021-05-24 17:56 Pacific
Severity: Medium
References: CVE-2020-25692 

Issue Overview:

A NULL pointer dereference flaw was found in the OpenLDAP server, during a request for renaming RDNs. This flaw allows a remote, unauthenticated attacker to crash the slapd process by sending a specially crafted request, causing a denial of service. The highest threat from this vulnerability is to system availability. (CVE-2020-25692 )


Affected Packages:

openldap


Issue Correction:
Run yum update openldap to update your system.

New Packages:
aarch64:
    openldap-2.4.44-23.amzn2.aarch64
    openldap-devel-2.4.44-23.amzn2.aarch64
    openldap-servers-2.4.44-23.amzn2.aarch64
    openldap-servers-sql-2.4.44-23.amzn2.aarch64
    openldap-clients-2.4.44-23.amzn2.aarch64
    openldap-debuginfo-2.4.44-23.amzn2.aarch64

i686:
    openldap-2.4.44-23.amzn2.i686
    openldap-devel-2.4.44-23.amzn2.i686
    openldap-servers-2.4.44-23.amzn2.i686
    openldap-servers-sql-2.4.44-23.amzn2.i686
    openldap-clients-2.4.44-23.amzn2.i686
    openldap-debuginfo-2.4.44-23.amzn2.i686

src:
    openldap-2.4.44-23.amzn2.src

x86_64:
    openldap-2.4.44-23.amzn2.x86_64
    openldap-devel-2.4.44-23.amzn2.x86_64
    openldap-servers-2.4.44-23.amzn2.x86_64
    openldap-servers-sql-2.4.44-23.amzn2.x86_64
    openldap-clients-2.4.44-23.amzn2.x86_64
    openldap-debuginfo-2.4.44-23.amzn2.x86_64