ALAS2-2021-1639


Amazon Linux 2 Security Advisory: ALAS-2021-1639
Advisory Release Date: 2021-05-20 16:07 Pacific
Advisory Updated Date: 2021-05-24 17:56 Pacific
Severity: Medium
References: CVE-2019-20916 

Issue Overview:

The pip package before 19.2 for Python allows Directory Traversal when a URL is given in an install command, because a Content-Disposition header can have ../ in a filename, as demonstrated by overwriting the /root/.ssh/authorized_keys file. This occurs in _download_http_url in _internal/download.py. (CVE-2019-20916 )


Affected Packages:

python-pip


Issue Correction:
Run yum update python-pip to update your system.

New Packages:
noarch:
    python2-pip-20.2.2-1.amzn2.0.2.noarch
    python3-pip-20.2.2-1.amzn2.0.2.noarch
    python-pip-wheel-20.2.2-1.amzn2.0.2.noarch

src:
    python-pip-20.2.2-1.amzn2.0.2.src