ALAS2-2021-1686


Amazon Linux 2 Security Advisory: ALAS-2021-1686
Advisory Release Date: 2021-07-14 20:38 Pacific
Advisory Updated Date: 2021-07-15 21:42 Pacific
Severity: Important
References: CVE-2021-31535 

Issue Overview:

A missing validation flaw was found in libX11. This flaw allows an attacker to inject X11 protocol commands on X clients, and in some cases, also bypass, authenticate (via injection of control characters), or potentially execute arbitrary code with permissions of the application compiled with libX11. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. (CVE-2021-31535)


Affected Packages:

libX11


Issue Correction:
Run yum update libX11 to update your system.

New Packages:
aarch64:
    libX11-1.6.7-3.amzn2.0.2.aarch64
    libX11-devel-1.6.7-3.amzn2.0.2.aarch64
    libX11-debuginfo-1.6.7-3.amzn2.0.2.aarch64

i686:
    libX11-1.6.7-3.amzn2.0.2.i686
    libX11-devel-1.6.7-3.amzn2.0.2.i686
    libX11-debuginfo-1.6.7-3.amzn2.0.2.i686

noarch:
    libX11-common-1.6.7-3.amzn2.0.2.noarch

src:
    libX11-1.6.7-3.amzn2.0.2.src

x86_64:
    libX11-1.6.7-3.amzn2.0.2.x86_64
    libX11-devel-1.6.7-3.amzn2.0.2.x86_64
    libX11-debuginfo-1.6.7-3.amzn2.0.2.x86_64