ALAS2-2021-1701


Amazon Linux 2 Security Advisory: ALAS-2021-1701
Advisory Release Date: 2021-09-08 23:35 Pacific
Advisory Updated Date: 2021-09-15 17:42 Pacific
Severity: Important
References: CVE-2021-31291 

Issue Overview:

A flaw was found in exiv2. A flawed bounds checking in the jp2Image.cpp:doWriteMetadata function leads to a heap-based buffer overflow. This flaw allows an attacker who can provide a malicious image to an application using the exiv2 library, to write data out of bounds and potentially execute code. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2021-31291)


Affected Packages:

exiv2


Issue Correction:
Run yum update exiv2 to update your system.

New Packages:
aarch64:
    exiv2-0.27.0-4.amzn2.0.1.aarch64
    exiv2-devel-0.27.0-4.amzn2.0.1.aarch64
    exiv2-libs-0.27.0-4.amzn2.0.1.aarch64
    exiv2-debuginfo-0.27.0-4.amzn2.0.1.aarch64

i686:
    exiv2-0.27.0-4.amzn2.0.1.i686
    exiv2-devel-0.27.0-4.amzn2.0.1.i686
    exiv2-libs-0.27.0-4.amzn2.0.1.i686
    exiv2-debuginfo-0.27.0-4.amzn2.0.1.i686

noarch:
    exiv2-doc-0.27.0-4.amzn2.0.1.noarch

src:
    exiv2-0.27.0-4.amzn2.0.1.src

x86_64:
    exiv2-0.27.0-4.amzn2.0.1.x86_64
    exiv2-devel-0.27.0-4.amzn2.0.1.x86_64
    exiv2-libs-0.27.0-4.amzn2.0.1.x86_64
    exiv2-debuginfo-0.27.0-4.amzn2.0.1.x86_64