Amazon Linux 2 (EOS) Security Advisory: ALAS2-2026-4058
Advisory Released Date: 2026-10-30
Advisory Updated Date: 2026-11-02
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.
This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected.
Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue. (CVE-2026-86243)
Affected Packages:
tomcat-native
Note:
This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.
Issue Correction:
Run yum update tomcat-native or yum update --advisory ALAS2-2026-4058 to update your system.
aarch64:
tomcat-native-1.2.38-3.amzn2.aarch64
tomcat-native-debuginfo-1.2.38-3.amzn2.aarch64
i686:
tomcat-native-1.2.38-3.amzn2.i686
tomcat-native-debuginfo-1.2.38-3.amzn2.i686
src:
tomcat-native-1.2.38-3.amzn2.src
x86_64:
tomcat-native-1.2.38-3.amzn2.x86_64
tomcat-native-debuginfo-1.2.38-3.amzn2.x86_64