ALAS2AWSCLI1-2026-002


Amazon Linux 2 (EOS) Security Advisory: ALAS2AWSCLI1-2026-002
Advisory Released Date: 2026-10-30
Advisory Updated Date: 2026-11-02
Severity: Medium

Issue Overview:

Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the umask has not been configured to restrict file permissions (the default on most systems) may allow other local users on the same host to read credentials written by certain CLI subcommands (aws codeartifact login, aws iam create-virtual-mfa-device, aws deploy register).

To remediate this issue, users should upgrade to AWS CLI 1.44.78 (v1) or 2.34.29 (v2) or later. (CVE-2026-13769)


Affected Packages:

awscli


Note:

This advisory is applicable to Amazon Linux 2 - Awscli1 Extra. Visit this page to learn more about Amazon Linux 2 (AL2) Extras and this FAQ section for the difference between AL2 Core and AL2 Extras advisories.


Issue Correction:
Run yum update awscli or yum update --advisory ALAS2AWSCLI1-2026-002 to update your system.

New Packages:
noarch:
    awscli-1.27.51-1.amzn2.0.3.noarch

src:
    awscli-1.27.51-1.amzn2.0.3.src