ALAS-2011-013


Amazon Linux AMI Security Advisory: ALAS-2011-13
Advisory Release Date: 2014-09-14 14:33 Pacific
Severity: Medium

Issue Overview:

Multiple input sanitization flaws were found in the X.Org GLX (OpenGL extension to the X Window System) extension. A malicious, authorized client could use these flaws to crash the X.Org server or, potentially, execute arbitrary code with root privileges. (CVE-2010-4818 )

An input sanitization flaw was found in the X.Org Render extension. A malicious, authorized client could use this flaw to leak arbitrary memory from the X.Org server process, or possibly crash the X.Org server. (CVE-2010-4819 )


Affected Packages:

xorg-x11-server


Issue Correction:
Run yum update xorg-x11-server to update your system.

New Packages:
i686:
    xorg-x11-server-Xvfb-1.7.7-29.10.amzn1.i686
    xorg-x11-server-Xephyr-1.7.7-29.10.amzn1.i686
    xorg-x11-server-common-1.7.7-29.10.amzn1.i686
    xorg-x11-server-Xnest-1.7.7-29.10.amzn1.i686
    xorg-x11-server-debuginfo-1.7.7-29.10.amzn1.i686

noarch:
    xorg-x11-server-source-1.7.7-29.10.amzn1.noarch

src:
    xorg-x11-server-1.7.7-29.10.amzn1.src

x86_64:
    xorg-x11-server-Xvfb-1.7.7-29.10.amzn1.x86_64
    xorg-x11-server-debuginfo-1.7.7-29.10.amzn1.x86_64
    xorg-x11-server-Xnest-1.7.7-29.10.amzn1.x86_64
    xorg-x11-server-common-1.7.7-29.10.amzn1.x86_64
    xorg-x11-server-Xephyr-1.7.7-29.10.amzn1.x86_64