ALAS-2011-024


Amazon Linux AMI Security Advisory: ALAS-2011-24
Advisory Release Date: 2014-09-14 15:03 Pacific
Severity: Important

Issue Overview:

A flaw was discovered in the way BIND handled certain DNS queries, which caused it to cache an invalid record. A remote attacker could use this flaw to send repeated queries for this invalid record, causing the resolvers to exit unexpectedly due to a failed assertion.


Affected Packages:

bind


Issue Correction:
Run yum update bind to update your system.

New Packages:
i686:
    bind-9.7.3-2.11.amzn1.i686
    bind-debuginfo-9.7.3-2.11.amzn1.i686
    bind-utils-9.7.3-2.11.amzn1.i686
    bind-sdb-9.7.3-2.11.amzn1.i686
    bind-chroot-9.7.3-2.11.amzn1.i686
    bind-libs-9.7.3-2.11.amzn1.i686
    bind-devel-9.7.3-2.11.amzn1.i686

src:
    bind-9.7.3-2.11.amzn1.src

x86_64:
    bind-libs-9.7.3-2.11.amzn1.x86_64
    bind-devel-9.7.3-2.11.amzn1.x86_64
    bind-9.7.3-2.11.amzn1.x86_64
    bind-debuginfo-9.7.3-2.11.amzn1.x86_64
    bind-chroot-9.7.3-2.11.amzn1.x86_64
    bind-sdb-9.7.3-2.11.amzn1.x86_64
    bind-utils-9.7.3-2.11.amzn1.x86_64