ALAS-2012-112


Amazon Linux AMI Security Advisory: ALAS-2012-112
Advisory Release Date: 2014-09-14 16:48 Pacific
Severity: Medium

Issue Overview:

Two format string flaws were found in perl-DBD-Pg. A specially-crafted database warning or error message from a server could cause an application using perl-DBD-Pg to crash or, potentially, execute arbitrary code with the privileges of the user running the application. (CVE-2012-1151 )


Affected Packages:

perl-DBD-Pg


Issue Correction:
Run yum update perl-DBD-Pg to update your system.

New Packages:
i686:
    perl-DBD-Pg-2.15.1-4.3.amzn1.i686
    perl-DBD-Pg-debuginfo-2.15.1-4.3.amzn1.i686

src:
    perl-DBD-Pg-2.15.1-4.3.amzn1.src

x86_64:
    perl-DBD-Pg-debuginfo-2.15.1-4.3.amzn1.x86_64
    perl-DBD-Pg-2.15.1-4.3.amzn1.x86_64