ALAS-2012-113


Amazon Linux AMI Security Advisory: ALAS-2012-113
Advisory Release Date: 2014-09-14 16:49 Pacific
Severity: Important

Issue Overview:

An uninitialized data structure use flaw was found in BIND when DNSSEC validation was enabled. A remote attacker able to send a large number of queries to a DNSSEC validating BIND resolver could use this flaw to cause it to exit unexpectedly with an assertion failure. (CVE-2012-3817 )


Affected Packages:

bind


Issue Correction:
Run yum update bind to update your system.

New Packages:
i686:
    bind-libs-9.8.2-0.10.rc1.23.amzn1.i686
    bind-9.8.2-0.10.rc1.23.amzn1.i686
    bind-sdb-9.8.2-0.10.rc1.23.amzn1.i686
    bind-debuginfo-9.8.2-0.10.rc1.23.amzn1.i686
    bind-utils-9.8.2-0.10.rc1.23.amzn1.i686
    bind-devel-9.8.2-0.10.rc1.23.amzn1.i686
    bind-chroot-9.8.2-0.10.rc1.23.amzn1.i686

src:
    bind-9.8.2-0.10.rc1.23.amzn1.src

x86_64:
    bind-sdb-9.8.2-0.10.rc1.23.amzn1.x86_64
    bind-utils-9.8.2-0.10.rc1.23.amzn1.x86_64
    bind-libs-9.8.2-0.10.rc1.23.amzn1.x86_64
    bind-debuginfo-9.8.2-0.10.rc1.23.amzn1.x86_64
    bind-9.8.2-0.10.rc1.23.amzn1.x86_64
    bind-devel-9.8.2-0.10.rc1.23.amzn1.x86_64
    bind-chroot-9.8.2-0.10.rc1.23.amzn1.x86_64