ALAS-2012-121


Amazon Linux AMI Security Advisory: ALAS-2012-121
Advisory Release Date: 2014-09-14 16:55 Pacific
Severity: Medium
References: CVE-2012-3488 

Issue Overview:

The libxslt support in contrib/xml2 in PostgreSQL 8.3 before 8.3.20, 8.4 before 8.4.13, 9.0 before 9.0.9, and 9.1 before 9.1.5 does not properly restrict access to files and URLs, which allows remote authenticated users to modify data, obtain sensitive information, or trigger outbound traffic to arbitrary external hosts by leveraging (1) stylesheet commands that are permitted by the libxslt security options or (2) an xslt_process feature, related to an XML External Entity (aka XXE) issue.


Affected Packages:

postgresql9


Issue Correction:
Run yum update postgresql9 to update your system.

New Packages:
i686:
    postgresql9-devel-9.1.5-1.23.amzn1.i686
    postgresql9-docs-9.1.5-1.23.amzn1.i686
    postgresql9-test-9.1.5-1.23.amzn1.i686
    postgresql9-pltcl-9.1.5-1.23.amzn1.i686
    postgresql9-9.1.5-1.23.amzn1.i686
    postgresql9-debuginfo-9.1.5-1.23.amzn1.i686
    postgresql9-plperl-9.1.5-1.23.amzn1.i686
    postgresql9-plpython-9.1.5-1.23.amzn1.i686
    postgresql9-contrib-9.1.5-1.23.amzn1.i686
    postgresql9-server-9.1.5-1.23.amzn1.i686
    postgresql9-libs-9.1.5-1.23.amzn1.i686

src:
    postgresql9-9.1.5-1.23.amzn1.src

x86_64:
    postgresql9-devel-9.1.5-1.23.amzn1.x86_64
    postgresql9-server-9.1.5-1.23.amzn1.x86_64
    postgresql9-plperl-9.1.5-1.23.amzn1.x86_64
    postgresql9-9.1.5-1.23.amzn1.x86_64
    postgresql9-pltcl-9.1.5-1.23.amzn1.x86_64
    postgresql9-libs-9.1.5-1.23.amzn1.x86_64
    postgresql9-docs-9.1.5-1.23.amzn1.x86_64
    postgresql9-test-9.1.5-1.23.amzn1.x86_64
    postgresql9-debuginfo-9.1.5-1.23.amzn1.x86_64
    postgresql9-contrib-9.1.5-1.23.amzn1.x86_64
    postgresql9-plpython-9.1.5-1.23.amzn1.x86_64