ALAS-2012-126


Amazon Linux AMI Security Advisory: ALAS-2012-126
Advisory Release Date: 2014-09-14 17:26 Pacific
Severity: Medium

Issue Overview:

Multiple flaws were found in the way libexif processed Exif tags. An attacker could create a specially-crafted image file that, when opened in an application linked against libexif, could cause the application to crash or, potentially, execute arbitrary code with the privileges of the user running the application.


Affected Packages:

libexif


Issue Correction:
Run yum update libexif to update your system.

New Packages:
i686:
    libexif-debuginfo-0.6.21-5.6.amzn1.i686
    libexif-0.6.21-5.6.amzn1.i686
    libexif-devel-0.6.21-5.6.amzn1.i686

src:
    libexif-0.6.21-5.6.amzn1.src

x86_64:
    libexif-devel-0.6.21-5.6.amzn1.x86_64
    libexif-0.6.21-5.6.amzn1.x86_64
    libexif-debuginfo-0.6.21-5.6.amzn1.x86_64