ALAS-2012-140


Amazon Linux AMI Security Advisory: ALAS-2012-140
Advisory Release Date: 2014-09-14 17:15 Pacific
Severity: Medium

Issue Overview:

A buffer overflow flaw was found in the way libproxy handled the downloading of proxy auto-configuration (PAC) files. A malicious server hosting a PAC file or a man-in-the-middle attacker could use this flaw to cause an application using libproxy to crash or, possibly, execute arbitrary code, if the proxy settings obtained by libproxy (from the environment or the desktop environment settings) instructed the use of a PAC proxy configuration. (CVE-2012-4505 )


Affected Packages:

libproxy


Issue Correction:
Run yum update libproxy to update your system.

New Packages:
i686:
    libproxy-bin-0.3.0-3.7.amzn1.i686
    libproxy-devel-0.3.0-3.7.amzn1.i686
    libproxy-python-0.3.0-3.7.amzn1.i686
    libproxy-debuginfo-0.3.0-3.7.amzn1.i686
    libproxy-0.3.0-3.7.amzn1.i686

src:
    libproxy-0.3.0-3.7.amzn1.src

x86_64:
    libproxy-python-0.3.0-3.7.amzn1.x86_64
    libproxy-0.3.0-3.7.amzn1.x86_64
    libproxy-bin-0.3.0-3.7.amzn1.x86_64
    libproxy-devel-0.3.0-3.7.amzn1.x86_64
    libproxy-debuginfo-0.3.0-3.7.amzn1.x86_64