ALAS-2012-143


Amazon Linux AMI Security Advisory: ALAS-2012-143
Advisory Release Date: 2014-09-14 17:18 Pacific
Severity: Important

Issue Overview:

A heap-based buffer underflow flaw was found in the way libxml2 decoded certain entities. A remote attacker could provide a specially-crafted XML file that, when opened in an application linked against libxml2, would cause the application to crash or, potentially, execute arbitrary code with the privileges of the user running the application. (CVE-2012-5134 )


Affected Packages:

libxml2


Issue Correction:
Run yum update libxml2 to update your system.

New Packages:
i686:
    libxml2-python-2.7.8-10.25.amzn1.i686
    libxml2-static-2.7.8-10.25.amzn1.i686
    libxml2-2.7.8-10.25.amzn1.i686
    libxml2-debuginfo-2.7.8-10.25.amzn1.i686
    libxml2-devel-2.7.8-10.25.amzn1.i686

src:
    libxml2-2.7.8-10.25.amzn1.src

x86_64:
    libxml2-static-2.7.8-10.25.amzn1.x86_64
    libxml2-debuginfo-2.7.8-10.25.amzn1.x86_64
    libxml2-2.7.8-10.25.amzn1.x86_64
    libxml2-python-2.7.8-10.25.amzn1.x86_64
    libxml2-devel-2.7.8-10.25.amzn1.x86_64