ALAS-2012-051


Amazon Linux AMI Security Advisory: ALAS-2012-51
Advisory Release Date: 2014-09-14 15:39 Pacific
Severity: Medium

Issue Overview:

A heap-based buffer overflow flaw was found in the way the CVS client handled responses from HTTP proxies. A malicious HTTP proxy could use this flaw to cause the CVS client to crash or, possibly, execute arbitrary code with the privileges of the user running the CVS client. (CVE-2012-0804 )


Affected Packages:

cvs


Issue Correction:
Run yum update cvs to update your system.

New Packages:
i686:
    cvs-debuginfo-1.11.23-11.6.amzn1.i686
    cvs-1.11.23-11.6.amzn1.i686

src:
    cvs-1.11.23-11.6.amzn1.src

x86_64:
    cvs-1.11.23-11.6.amzn1.x86_64
    cvs-debuginfo-1.11.23-11.6.amzn1.x86_64