ALAS-2012-052


Amazon Linux AMI Security Advisory: ALAS-2012-52
Advisory Release Date: 2014-09-14 15:39 Pacific
Severity: Medium

Issue Overview:

It was found that the hashing routine used by libxml2 arrays was susceptible to predictable hash collisions. Sending a specially-crafted message to an XML service could result in longer processing time, which could lead to a denial of service. To mitigate this issue, randomization has been added to the hashing function to reduce the chance of an attacker successfully causing intentional collisions. (CVE-2012-0841 )


Affected Packages:

libxml2


Issue Correction:
Run yum update libxml2 to update your system.

New Packages:
i686:
    libxml2-python-2.7.6-4.12.amzn1.i686
    libxml2-debuginfo-2.7.6-4.12.amzn1.i686
    libxml2-devel-2.7.6-4.12.amzn1.i686
    libxml2-2.7.6-4.12.amzn1.i686
    libxml2-static-2.7.6-4.12.amzn1.i686

src:
    libxml2-2.7.6-4.12.amzn1.src

x86_64:
    libxml2-devel-2.7.6-4.12.amzn1.x86_64
    libxml2-2.7.6-4.12.amzn1.x86_64
    libxml2-python-2.7.6-4.12.amzn1.x86_64
    libxml2-debuginfo-2.7.6-4.12.amzn1.x86_64
    libxml2-static-2.7.6-4.12.amzn1.x86_64