ALAS-2012-057


Amazon Linux AMI Security Advisory: ALAS-2012-57
Advisory Release Date: 2014-09-14 15:43 Pacific
Severity: Medium

Issue Overview:

An integer overflow flaw was found in the implementation of the printf functions family. This could allow an attacker to bypass FORTIFY_SOURCE protections and execute arbitrary code using a format string flaw in an application, even though these protections are expected to limit the impact of such flaws to an application abort. (CVE-2012-0864 )


Affected Packages:

glibc


Issue Correction:
Run yum update glibc to update your system.

New Packages:
i686:
    glibc-static-2.12-1.47.37.amzn1.i686
    glibc-debuginfo-common-2.12-1.47.37.amzn1.i686
    glibc-utils-2.12-1.47.37.amzn1.i686
    glibc-devel-2.12-1.47.37.amzn1.i686
    glibc-2.12-1.47.37.amzn1.i686
    glibc-common-2.12-1.47.37.amzn1.i686
    glibc-headers-2.12-1.47.37.amzn1.i686
    glibc-debuginfo-2.12-1.47.37.amzn1.i686
    nscd-2.12-1.47.37.amzn1.i686

src:
    glibc-2.12-1.47.37.amzn1.src

x86_64:
    nscd-2.12-1.47.37.amzn1.x86_64
    glibc-devel-2.12-1.47.37.amzn1.x86_64
    glibc-debuginfo-common-2.12-1.47.37.amzn1.x86_64
    glibc-2.12-1.47.37.amzn1.x86_64
    glibc-headers-2.12-1.47.37.amzn1.x86_64
    glibc-debuginfo-2.12-1.47.37.amzn1.x86_64
    glibc-static-2.12-1.47.37.amzn1.x86_64
    glibc-utils-2.12-1.47.37.amzn1.x86_64
    glibc-common-2.12-1.47.37.amzn1.x86_64