ALAS-2012-058


Amazon Linux AMI Security Advisory: ALAS-2012-58
Advisory Release Date: 2014-09-14 15:44 Pacific
Severity: Medium
References: CVE-2012-1568 

Issue Overview:

The ExecShield feature does not properly handle use of many shared libraries by a 32-bit executable file, which makes it easier for context-dependent attackers to bypass the ASLR protection mechanism by leveraging a predictable base address for one of these libraries.


Affected Packages:

kernel


Issue Correction:
Run yum update kernel to update your system. You will need to reboot your system in order for the new kernel to be running.

New Packages:
i686:
    kernel-devel-3.2.12-3.2.4.amzn1.i686
    kernel-debuginfo-common-i686-3.2.12-3.2.4.amzn1.i686
    kernel-headers-3.2.12-3.2.4.amzn1.i686
    kernel-debuginfo-3.2.12-3.2.4.amzn1.i686
    kernel-3.2.12-3.2.4.amzn1.i686

noarch:
    kernel-doc-3.2.12-3.2.4.amzn1.noarch

src:
    kernel-3.2.12-3.2.4.amzn1.src

x86_64:
    kernel-debuginfo-common-x86_64-3.2.12-3.2.4.amzn1.x86_64
    kernel-3.2.12-3.2.4.amzn1.x86_64
    kernel-headers-3.2.12-3.2.4.amzn1.x86_64
    kernel-debuginfo-3.2.12-3.2.4.amzn1.x86_64
    kernel-devel-3.2.12-3.2.4.amzn1.x86_64