ALAS-2012-080


Amazon Linux AMI Security Advisory: ALAS-2012-80
Advisory Release Date: 2014-09-14 16:11 Pacific
Severity: Medium
References: CVE-2012-0845 

Issue Overview:

SimpleXMLRPCServer.py in SimpleXMLRPCServer in Python before 2.6.8, 2.7.x before 2.7.3, 3.x before 3.1.5, and 3.2.x before 3.2.3 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via an XML-RPC POST request that contains a smaller amount of data than specified by the Content-Length header.


Affected Packages:

python26


Issue Correction:
Run yum update python26 to update your system.

New Packages:
i686:
    python26-devel-2.6.8-1.45.amzn1.i686
    python26-tools-2.6.8-1.45.amzn1.i686
    python26-test-2.6.8-1.45.amzn1.i686
    python26-debuginfo-2.6.8-1.45.amzn1.i686
    python26-2.6.8-1.45.amzn1.i686
    python26-libs-2.6.8-1.45.amzn1.i686

src:
    python26-2.6.8-1.45.amzn1.src

x86_64:
    python26-debuginfo-2.6.8-1.45.amzn1.x86_64
    python26-devel-2.6.8-1.45.amzn1.x86_64
    python26-2.6.8-1.45.amzn1.x86_64
    python26-libs-2.6.8-1.45.amzn1.x86_64
    python26-test-2.6.8-1.45.amzn1.x86_64
    python26-tools-2.6.8-1.45.amzn1.x86_64