ALAS-2012-083


Amazon Linux AMI Security Advisory: ALAS-2012-83
Advisory Release Date: 2014-09-14 16:13 Pacific
Severity: Medium

Issue Overview:

It was found that the data_len parameter of the sock_alloc_send_pskb() function in the Linux kernel's networking implementation was not validated before use. A local user with access to a TUN/TAP virtual interface could use this flaw to crash the system or, potentially, escalate their privileges. Note that unprivileged users cannot access TUN/TAP devices until the root user grants them access. (CVE-2012-2136 , Important)


Affected Packages:

kernel


Issue Correction:
Run yum update kernel to update your system. You will need to reboot your system in order for the new kernel to be running.

New Packages:
i686:
    kernel-headers-3.2.19-1.28.6.amzn1.i686
    kernel-tools-3.2.19-1.28.6.amzn1.i686
    kernel-3.2.19-1.28.6.amzn1.i686
    kernel-devel-3.2.19-1.28.6.amzn1.i686
    kernel-debuginfo-common-i686-3.2.19-1.28.6.amzn1.i686
    kernel-tools-debuginfo-3.2.19-1.28.6.amzn1.i686
    kernel-debuginfo-3.2.19-1.28.6.amzn1.i686

noarch:
    kernel-doc-3.2.19-1.28.6.amzn1.noarch

src:
    kernel-3.2.19-1.28.6.amzn1.src

x86_64:
    kernel-tools-debuginfo-3.2.19-1.28.6.amzn1.x86_64
    kernel-tools-3.2.19-1.28.6.amzn1.x86_64
    kernel-debuginfo-3.2.19-1.28.6.amzn1.x86_64
    kernel-devel-3.2.19-1.28.6.amzn1.x86_64
    kernel-debuginfo-common-x86_64-3.2.19-1.28.6.amzn1.x86_64
    kernel-headers-3.2.19-1.28.6.amzn1.x86_64
    kernel-3.2.19-1.28.6.amzn1.x86_64