ALAS-2012-086


Amazon Linux AMI Security Advisory: ALAS-2012-86
Advisory Release Date: 2014-09-14 16:19 Pacific
Severity: Medium
References: CVE-2012-2417 

Issue Overview:

PyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.


Affected Packages:

python-crypto


Issue Correction:
Run yum update python-crypto to update your system.

New Packages:
i686:
    python-crypto-2.3-6.5.amzn1.i686
    python-crypto-debuginfo-2.3-6.5.amzn1.i686

src:
    python-crypto-2.3-6.5.amzn1.src

x86_64:
    python-crypto-debuginfo-2.3-6.5.amzn1.x86_64
    python-crypto-2.3-6.5.amzn1.x86_64