ALAS-2012-089


Amazon Linux AMI Security Advisory: ALAS-2012-89
Advisory Release Date: 2014-09-14 16:21 Pacific
Severity: Medium

Issue Overview:

A denial of service flaw was found in the implementation of hash arrays in Expat. An attacker could use this flaw to make an application using Expat consume an excessive amount of CPU time by providing a specially-crafted XML file that triggers multiple hash function collisions. To mitigate this issue, randomization has been added to the hash function to reduce the chance of an attacker successfully causing intentional collisions. (CVE-2012-0876 )

A memory leak flaw was found in Expat. If an XML file processed by an application linked against Expat triggered a memory re-allocation failure, Expat failed to free the previously allocated memory. This could cause the application to exit unexpectedly or crash when all available memory is exhausted. (CVE-2012-1148 )


Affected Packages:

expat


Issue Correction:
Run yum update expat to update your system.

New Packages:
i686:
    expat-devel-2.0.1-11.9.amzn1.i686
    expat-debuginfo-2.0.1-11.9.amzn1.i686
    expat-2.0.1-11.9.amzn1.i686

src:
    expat-2.0.1-11.9.amzn1.src

x86_64:
    expat-devel-2.0.1-11.9.amzn1.x86_64
    expat-2.0.1-11.9.amzn1.x86_64
    expat-debuginfo-2.0.1-11.9.amzn1.x86_64