ALAS-2013-180


Amazon Linux AMI Security Advisory: ALAS-2013-180
Advisory Release Date: 2014-09-15 22:50 Pacific
Severity: Medium

Issue Overview:

A NULL pointer dereference flaw was found in the way the mod_dav_svn module handled PROPFIND requests on activity URLs. A remote attacker could use this flaw to cause the httpd process serving the request to crash. (CVE-2013-1849 )

A flaw was found in the way the mod_dav_svn module handled large numbers of properties (such as those set with the "svn propset" command). A malicious, remote user could use this flaw to cause the httpd process serving the request to consume an excessive amount of system memory. (CVE-2013-1845 )

Two NULL pointer dereference flaws were found in the way the mod_dav_svn module handled LOCK requests on certain types of URLs. A malicious, remote user could use these flaws to cause the httpd process serving the request to crash. (CVE-2013-1846 , CVE-2013-1847 )

Note: The CVE-2013-1849 , CVE-2013-1846 , and CVE-2013-1847 issues only caused a temporary denial of service, as the Apache HTTP Server started a new process to replace the crashed child process. When using prefork MPM, the crash only affected the attacker. When using worker (threaded) MPM, the connections of other users may have been interrupted.


Affected Packages:

subversion


Issue Correction:
Run yum update subversion to update your system.

New Packages:
i686:
    subversion-devel-1.7.9-1.28.amzn1.i686
    subversion-javahl-1.7.9-1.28.amzn1.i686
    subversion-perl-1.7.9-1.28.amzn1.i686
    subversion-ruby-1.7.9-1.28.amzn1.i686
    mod_dav_svn-1.7.9-1.28.amzn1.i686
    subversion-libs-1.7.9-1.28.amzn1.i686
    subversion-debuginfo-1.7.9-1.28.amzn1.i686
    subversion-tools-1.7.9-1.28.amzn1.i686
    subversion-python-1.7.9-1.28.amzn1.i686
    subversion-1.7.9-1.28.amzn1.i686

src:
    subversion-1.7.9-1.28.amzn1.src

x86_64:
    subversion-debuginfo-1.7.9-1.28.amzn1.x86_64
    subversion-javahl-1.7.9-1.28.amzn1.x86_64
    subversion-tools-1.7.9-1.28.amzn1.x86_64
    subversion-perl-1.7.9-1.28.amzn1.x86_64
    subversion-1.7.9-1.28.amzn1.x86_64
    mod_dav_svn-1.7.9-1.28.amzn1.x86_64
    subversion-devel-1.7.9-1.28.amzn1.x86_64
    subversion-python-1.7.9-1.28.amzn1.x86_64
    subversion-ruby-1.7.9-1.28.amzn1.x86_64
    subversion-libs-1.7.9-1.28.amzn1.x86_64