ALAS-2013-190


Amazon Linux AMI Security Advisory: ALAS-2013-190
Advisory Release Date: 2014-09-15 23:02 Pacific
Severity: Medium
References: CVE-2013-2094 

Issue Overview:

The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9 uses an incorrect integer data type, which allows local users to gain privileges via a crafted perf_event_open system call.


Affected Packages:

kernel


Issue Correction:
Run yum update kernel to update your system. You will need to reboot your system in order for the new kernel to be running.

New Packages:
i686:
    kernel-tools-3.4.43-43.43.amzn1.i686
    kernel-headers-3.4.43-43.43.amzn1.i686
    kernel-debuginfo-3.4.43-43.43.amzn1.i686
    kernel-tools-debuginfo-3.4.43-43.43.amzn1.i686
    kernel-debuginfo-common-i686-3.4.43-43.43.amzn1.i686
    kernel-devel-3.4.43-43.43.amzn1.i686
    kernel-3.4.43-43.43.amzn1.i686

noarch:
    kernel-doc-3.4.43-43.43.amzn1.noarch

src:
    kernel-3.4.43-43.43.amzn1.src

x86_64:
    kernel-headers-3.4.43-43.43.amzn1.x86_64
    kernel-3.4.43-43.43.amzn1.x86_64
    kernel-debuginfo-common-x86_64-3.4.43-43.43.amzn1.x86_64
    kernel-tools-3.4.43-43.43.amzn1.x86_64
    kernel-tools-debuginfo-3.4.43-43.43.amzn1.x86_64
    kernel-devel-3.4.43-43.43.amzn1.x86_64
    kernel-debuginfo-3.4.43-43.43.amzn1.x86_64