ALAS-2013-191


Amazon Linux AMI Security Advisory: ALAS-2013-191
Advisory Release Date: 2014-09-15 23:05 Pacific
Severity: Low
References: CVE-2013-2071 

Issue Overview:

java/org/apache/catalina/core/AsyncContextImpl.java in Apache Tomcat 7.x before 7.0.40 does not properly handle the throwing of a RuntimeException in an AsyncListener in an application, which allows context-dependent attackers to obtain sensitive request information intended for other applications in opportunistic circumstances via an application that records the requests that it processes.


Affected Packages:

tomcat7


Issue Correction:
Run yum update tomcat7 to update your system.

New Packages:
noarch:
    tomcat7-lib-7.0.40-1.26.amzn1.noarch
    tomcat7-jsp-2.2-api-7.0.40-1.26.amzn1.noarch
    tomcat7-webapps-7.0.40-1.26.amzn1.noarch
    tomcat7-javadoc-7.0.40-1.26.amzn1.noarch
    tomcat7-docs-webapp-7.0.40-1.26.amzn1.noarch
    tomcat7-admin-webapps-7.0.40-1.26.amzn1.noarch
    tomcat7-el-2.2-api-7.0.40-1.26.amzn1.noarch
    tomcat7-7.0.40-1.26.amzn1.noarch
    tomcat7-servlet-3.0-api-7.0.40-1.26.amzn1.noarch

src:
    tomcat7-7.0.40-1.26.amzn1.src