ALAS-2013-198


Amazon Linux AMI Security Advisory: ALAS-2013-198
Advisory Release Date: 2014-09-15 23:09 Pacific
Severity: Medium

Issue Overview:

An out-of-bounds access flaw was found in Mesa. If an application using Mesa exposed the Mesa API to untrusted inputs (Mozilla Firefox does this), an attacker could cause the application to crash or, potentially, execute arbitrary code with the privileges of the user running the application. (CVE-2013-1872 )

It was found that Mesa did not correctly validate messages from the X server. A malicious X server could cause an application using Mesa to crash or, potentially, execute arbitrary code with the privileges of the user running the application. (CVE-2013-1993 )


Affected Packages:

mesa


Issue Correction:
Run yum update mesa to update your system.

New Packages:
i686:
    glx-utils-9.0-0.8.15.amzn1.i686
    mesa-libGL-devel-9.0-0.8.15.amzn1.i686
    mesa-debuginfo-9.0-0.8.15.amzn1.i686
    mesa-libGL-9.0-0.8.15.amzn1.i686
    mesa-libGLU-9.0-0.8.15.amzn1.i686
    mesa-libGLU-devel-9.0-0.8.15.amzn1.i686
    mesa-libOSMesa-devel-9.0-0.8.15.amzn1.i686
    mesa-libOSMesa-9.0-0.8.15.amzn1.i686

src:
    mesa-9.0-0.8.15.amzn1.src

x86_64:
    mesa-debuginfo-9.0-0.8.15.amzn1.x86_64
    mesa-libOSMesa-9.0-0.8.15.amzn1.x86_64
    mesa-libGLU-9.0-0.8.15.amzn1.x86_64
    glx-utils-9.0-0.8.15.amzn1.x86_64
    mesa-libGL-devel-9.0-0.8.15.amzn1.x86_64
    mesa-libGL-9.0-0.8.15.amzn1.x86_64
    mesa-libGLU-devel-9.0-0.8.15.amzn1.x86_64
    mesa-libOSMesa-devel-9.0-0.8.15.amzn1.x86_64