ALAS-2013-219


Amazon Linux AMI Security Advisory: ALAS-2013-219
Advisory Release Date: 2014-09-15 23:21 Pacific
Severity: Medium

Issue Overview:

Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service. NOTE: this vulnerability can only be exploited utilizing unspecified "local file system access" to the Puppet Master.

Puppet Module Tool (PMT), as used in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, installs modules with weak permissions if those permissions were used when the modules were originally built, which might allow local users to read or modify those modules depending on the original permissions.


Affected Packages:

puppet


Issue Correction:
Run yum update puppet to update your system.

New Packages:
i686:
    puppet-debuginfo-2.7.23-1.0.amzn1.i686
    puppet-2.7.23-1.0.amzn1.i686
    puppet-server-2.7.23-1.0.amzn1.i686

src:
    puppet-2.7.23-1.0.amzn1.src

x86_64:
    puppet-debuginfo-2.7.23-1.0.amzn1.x86_64
    puppet-2.7.23-1.0.amzn1.x86_64
    puppet-server-2.7.23-1.0.amzn1.x86_64