ALAS-2013-223


Amazon Linux AMI Security Advisory: ALAS-2013-223
Advisory Release Date: 2014-09-15 23:23 Pacific
Severity: Important

Issue Overview:

ns-slapd in 389 Directory Server before 1.3.0.8 allows remote attackers to cause a denial of service (server crash) via a crafted Distinguished Name (DN) in a MOD operation request.

389 Directory Server does not properly restrict access to entity attributes, which allows remote authenticated users to obtain sensitive information via a search query for the attribute.


Affected Packages:

389-ds-base


Issue Correction:
Run yum update 389-ds-base to update your system.

New Packages:
i686:
    389-ds-base-devel-1.3.1.8-1.5.amzn1.i686
    389-ds-base-1.3.1.8-1.5.amzn1.i686
    389-ds-base-libs-1.3.1.8-1.5.amzn1.i686
    389-ds-base-debuginfo-1.3.1.8-1.5.amzn1.i686

src:
    389-ds-base-1.3.1.8-1.5.amzn1.src

x86_64:
    389-ds-base-debuginfo-1.3.1.8-1.5.amzn1.x86_64
    389-ds-base-libs-1.3.1.8-1.5.amzn1.x86_64
    389-ds-base-devel-1.3.1.8-1.5.amzn1.x86_64
    389-ds-base-1.3.1.8-1.5.amzn1.x86_64