ALAS-2013-229


Amazon Linux AMI Security Advisory: ALAS-2013-229
Advisory Release Date: 2014-09-16 21:40 Pacific
Severity: Low
References: CVE-2013-2065 

Issue Overview:

(1) DL and (2) Fiddle in Ruby 1.9 before 1.9.3 patchlevel 426, and 2.0 before 2.0.0 patchlevel 195, do not perform taint checking for native functions, which allows context-dependent attackers to bypass intended $SAFE level restrictions.


Affected Packages:

ruby19


Issue Correction:
Run yum update ruby19 to update your system.

New Packages:
i686:
    ruby19-debuginfo-1.9.3.448-31.53.amzn1.i686
    rubygem19-io-console-0.3-31.53.amzn1.i686
    rubygem19-bigdecimal-1.1.0-31.53.amzn1.i686
    ruby19-doc-1.9.3.448-31.53.amzn1.i686
    ruby19-devel-1.9.3.448-31.53.amzn1.i686
    ruby19-libs-1.9.3.448-31.53.amzn1.i686
    rubygem19-json-1.5.5-31.53.amzn1.i686
    ruby19-1.9.3.448-31.53.amzn1.i686

noarch:
    rubygem19-rake-0.9.2.2-31.53.amzn1.noarch
    ruby19-irb-1.9.3.448-31.53.amzn1.noarch
    rubygem19-rdoc-3.9.5-31.53.amzn1.noarch
    rubygems19-devel-1.8.23-31.53.amzn1.noarch
    rubygems19-1.8.23-31.53.amzn1.noarch
    rubygem19-minitest-2.5.1-31.53.amzn1.noarch

src:
    ruby19-1.9.3.448-31.53.amzn1.src

x86_64:
    ruby19-1.9.3.448-31.53.amzn1.x86_64
    rubygem19-json-1.5.5-31.53.amzn1.x86_64
    ruby19-doc-1.9.3.448-31.53.amzn1.x86_64
    ruby19-libs-1.9.3.448-31.53.amzn1.x86_64
    rubygem19-io-console-0.3-31.53.amzn1.x86_64
    ruby19-debuginfo-1.9.3.448-31.53.amzn1.x86_64
    rubygem19-bigdecimal-1.1.0-31.53.amzn1.x86_64
    ruby19-devel-1.9.3.448-31.53.amzn1.x86_64