ALAS-2013-234


Amazon Linux AMI Security Advisory: ALAS-2013-234
Advisory Release Date: 2014-09-16 21:44 Pacific
Severity: Important

Issue Overview:

A use-after-free flaw was found in the way the X.Org server handled ImageText requests. A malicious, authorized client could use this flaw to crash the X.Org server or, potentially, execute arbitrary code with root privileges. (CVE-2013-4396 )


Affected Packages:

xorg-x11-server


Issue Correction:
Run yum update xorg-x11-server to update your system.

New Packages:
i686:
    xorg-x11-server-debuginfo-1.13.0-11.18.amzn1.i686
    xorg-x11-server-common-1.13.0-11.18.amzn1.i686
    xorg-x11-server-Xnest-1.13.0-11.18.amzn1.i686
    xorg-x11-server-Xvfb-1.13.0-11.18.amzn1.i686
    xorg-x11-server-Xephyr-1.13.0-11.18.amzn1.i686

noarch:
    xorg-x11-server-source-1.13.0-11.18.amzn1.noarch

src:
    xorg-x11-server-1.13.0-11.18.amzn1.src

x86_64:
    xorg-x11-server-Xephyr-1.13.0-11.18.amzn1.x86_64
    xorg-x11-server-Xnest-1.13.0-11.18.amzn1.x86_64
    xorg-x11-server-debuginfo-1.13.0-11.18.amzn1.x86_64
    xorg-x11-server-Xvfb-1.13.0-11.18.amzn1.x86_64
    xorg-x11-server-common-1.13.0-11.18.amzn1.x86_64