ALAS-2013-258


Amazon Linux AMI Security Advisory: ALAS-2013-258
Advisory Release Date: 2014-09-16 22:08 Pacific
Severity: Low
References: CVE-2013-6382 

Issue Overview:

Multiple buffer underflows in the XFS implementation in the Linux kernel through 3.12.1 allow local users to cause a denial of service (memory corruption) or possibly have unspecified other impact by leveraging the CAP_SYS_ADMIN capability for a (1) XFS_IOC_ATTRLIST_BY_HANDLE or (2) XFS_IOC_ATTRLIST_BY_HANDLE_32 ioctl call with a crafted length value, related to the xfs_attrlist_by_handle function in fs/xfs/xfs_ioctl.c and the xfs_compat_attrlist_by_handle function in fs/xfs/xfs_ioctl32.c.


Affected Packages:

kernel


Issue Correction:
Run yum update kernel to update your system. You will need to reboot your system in order for the new kernel to be running.

New Packages:
i686:
    kernel-tools-debuginfo-3.4.73-64.112.amzn1.i686
    kernel-debuginfo-3.4.73-64.112.amzn1.i686
    kernel-debuginfo-common-i686-3.4.73-64.112.amzn1.i686
    kernel-headers-3.4.73-64.112.amzn1.i686
    kernel-3.4.73-64.112.amzn1.i686
    kernel-tools-3.4.73-64.112.amzn1.i686
    kernel-devel-3.4.73-64.112.amzn1.i686

noarch:
    kernel-doc-3.4.73-64.112.amzn1.noarch

src:
    kernel-3.4.73-64.112.amzn1.src

x86_64:
    kernel-debuginfo-3.4.73-64.112.amzn1.x86_64
    kernel-3.4.73-64.112.amzn1.x86_64
    kernel-headers-3.4.73-64.112.amzn1.x86_64
    kernel-tools-3.4.73-64.112.amzn1.x86_64
    kernel-debuginfo-common-x86_64-3.4.73-64.112.amzn1.x86_64
    kernel-tools-debuginfo-3.4.73-64.112.amzn1.x86_64
    kernel-devel-3.4.73-64.112.amzn1.x86_64